Общая последовательность установки плагина DAO для livestreet




  1. скопировать содержимое архива в папку /plugins (для AltoCMS - /common/plugins)

  2. положить файл с лицензией для вашего домена в папку /plugins/dao ( license.txt должен находится на одном уровне с главным классом плагина файлом Plugin%plugin_name%.class.php )

  3. на папку config плагина нужно выставить chmod 777 для записи информации об активных каталогах.(в дальнейшем, после создания всех разделов из админки рекомендуется вернуть 755).

  4. залогинившись под администратором на сайте и пройдите по адресу /admin/plugins - активируйте устанавливаемый плагин нажатием кнопки "Активировать".

  5. Управление плагином, настройка и создание разделов происходит по адресу site.ru/daoadmin/

  6. Если вы ставите плагин для версии 1.* вам необходимо в файл config/config.data.php прописать значения buy_code и config_code (были присланы по почте вместе с лицензией).

  7. Установка завершена!

  8. Теперь внимательно изучите и выставите под себя настройки конфига перед рабочим вводом плагина в эксплуатацию. Настройте параметры карты, размер загружаемых файлов и некоторые другие параметры, они прокомментированы в конфиге.



Обновление плагина



1)Сделать бэкап папки dao, включая license.txt и /config/paths.dat, а также, если у вас версия плагина для LS 1.0.* - /config/config.data.php
2)Удалить папку dao из папки плагинов, заменив ее новой из архива
3)Из бэкапа добавить файл лицензии в корень плагина и добавить файлы paths.dat и config.data.php в папку /config
4)Переактивировать плагин из админки (деактивировать, затем заново активировать)

готово!

Апгрейд 0.5 => 1.0


0)сделать бэкап плагина из 0,51, сделать бэкап БД. Сохранить файлы license.txt, config/paths.dat, config.data.php (если был).
1)Если при покупке не получались параметры buy_code и config_code, то получить их, написав по адресу support@lsmods.ru данные на которые покупался плагин (емайл и домен).
2)Установить плагин по инструкции в начале этой статьи.
3)При возникновении трудностей при установке писать на support@lsmods.ru

Дополнительные инструкции





-------------------------------------------------------------------------

PS* Если при установке вылетает ошибка отсутствия расширения ionCube есть два варианта решения проблемы в зависимости от вашего хостинга:
Для владельцев собственных серверов и VPS - установите его на сервер скачав нужную вашей ОС версию отсюда - http://www.ioncube.com/loaders.php
Если вы используете shared хостинг - обратитесь в службу поддержки для установки расширения ionCube.
Устанавливаемая версия ionCube должна быть 4.4.0 и выше.

Пример установки ioncube для linux сервера: http://sudouser.com/ustanovka-ioncube-loader-v-linux.html